Test Plans

This chapter explains how to create, search, clone, edit, tag, print, disable, and export a Test Plan in Kiwi TCMS.

Searching for Test Plans

To view the Test Plans you have created, click Personal menu::My Test Plans.

My Test Plans menu

Other Test Plans can be searched via the SEARCH item in the Main menu:

  1. Click SEARCH::Search Test Plans

    The Search menu

  2. In the Search Plan screen, enter the required search details.

    The Search Plan screen

  3. Click the Search button and the search results appear.

  4. To sort on a column, click the column heading.

    Click column to sort by.

Note

There is no need to use wildcard characters. The search results show all occurrences of the string, regardless of location. For example, searching for the Plan Name ‘x11’ will return plans named ‘xorg-x11’ and ‘libX11’.

Creating a Test Plan

A Test Plan should identify which features of a product will be tested and what the overall test strategy is. This is a high level document which should not include specific testing steps. It is recommended to use an IEEE 829 Test Plan format but you are free to enter any kind of text. To create a Test Plan:

  1. From the Main menu, click TESTING::New Test Plan.

    The Planning menu 1

  2. In the Create New Test Plan screen, perform the following actions:

    • Enter the Plan Name
    • Select the Product
    • Select the Product Version
    • Select the Type of Test Plan
    • Enter the Parent ID, this is optional
    • In the Plan Document text box do one of the following:
      • Enter the details of the Test Plan or
      • Click Browse, select the file to upload, and then click Upload. Supported formats: html, plain text, and ODT.
    • Select an Environment Group, this is optional
    • Enter a Reference Link to any additional information (eg. a wiki page), this is optional

    The Create New Test Plans screen

  3. Click the Create Test Plan button

Cloning a Test Plan

Cloning allows a user to replicate an existing Test Plan for a new product or a new version of the current product. To clone a Test Plan:

  1. Open the Test Plan which will be cloned.

  2. Click the Clone Plan button.

    The Clone plan button

  3. In the Clone Test Plan screen, perform the following actions:

    • Enter the New Plan Name.
    • In Copy to Product, select the product.
    • In Product Version, select the version.
    • Tick the Copy Settings you want

    The Clone Test Plan screen

  4. Click the Clone button and the new Test Plan will be created.

Editing a Test Plan

The Edit function modifies fields in a Test Plan. It does not change any Test Cases or Test Runs associated with the Test Plan. To edit a Test Plan:

  1. Open the Test Plan to be edited.

  2. Click the Edit plan button.

    The Edit plan button

  3. Edit the fields as required:

    Edit a Test Plan

  4. Click the Save button.

Edit History

To view the changelog of a Test Plan document, click the View Edit History in the Document tab of the Test Plan.

View Test Plan Edit History

Default Components

Kiwi TCMS allows adding default components for a Test Plan. The default components will be added to each Test Case belonging to the plan. To edit default components:

  1. Open the Test Plan to be edited.

  2. Click Default Components tab

    The Default Components tab.

  3. To Add a component:

    • Click Update components.
    • Select the components.
    • Click the Update button

    The update components selection screen.

  4. To Remove a component:

    • Select the components to remove.
    • Click the Remove button

Test Plan Tags

The tag function is used to classify and organize Test Plans. Test Plans may be searched/filtered by tag and they can have more than one tag. To add a new tag:

  1. Open the Test Plan to be edited.

  2. Click the Tags tab

    The Tags tab.

  3. Enter tag name next to the Add Tag label.

  4. Click the Add button.

  5. To remove a tag click the Remove action.

Updating the default tester

The default tester for a Test Case can be edited in the Test Plan window:

  1. Click the Cases tab.

  2. Select the Test Cases to be updated.

  3. Click the Default tester button.

    The default tester screen

  4. Enter the new tester’s email.

  5. Click Ok.

Using Tree View

The Tree View tab shows the current plan, its parents and children using a tree style layout. It provides the ability to edit both parent and child plans.

The Tree View screen.

Procedure: Changing the parent node

To change the parent node.

  1. Click Tree View tab.

  2. Click Change parent node.

    Change parent.

  3. Enter the parent node ID.

  4. Click Ok. The tree updates.

  5. Verify the changes and click Submit. The tree updates.

Procedure: Adding child nodes

To add child nodes.

  1. Click Tree View tab.

  2. Click Add child node.

    Add child node.

  3. Enter the child node IDs. Separate multiple IDs with a comma.

  4. Click Ok.

  5. Verify the changes and click Submit. The tree updates.

Procedure: Removing child nodes

To remove child nodes.

  1. Click Tree View tab.

  2. Click Remove child node.

    Remove child node.

  3. Enter the child node IDs. Separate multiple IDs with a comma.

  4. Click Ok.

  5. Verify the changes. and click Submit. The tree updates.

Disabling a Test Plan

This section outlines the process for disabling a Test Plan in Kiwi TCMS. A disabled Test Plan can not be used to create Test Runs. However, unlike deletion, it does not permanently remove the Test Plan from the database. It is best to disable older Test Plans instead of deleting them otherwise you will lose your testing history. To disable a Test Plan:

  1. Open the Test Plan to be disabled.

  2. Click Disable Plan button.

    The disable plan button.

    The plan name changes to a strike through font.

  3. To enable a disabled plan, click Enable plan.

    The enable plan button.

Printing a Test Plan

To print a Test Plan:

  1. Open the Test Plan to be printed.

  2. Click Print Plan button.

    The Print Plan button

  3. A printer friednly version displays.

  4. From the File menu in your Browser, click Print.

Exporting Test Cases from a Test Plan

Kiwi TCMS can export XML file listing all the Test Cases related to the current Test Plan. These files can be used as a form of backup or to interface with other systems however we recommend to use the API library instead. To export a Test Plan:

  1. Open the Test Plan to be exported.

  2. Exporting Test Cases:

    • All: click Export all cases button at the top.

      The Export all cases button

    • Selected: tick the Test Cases to export, click Case::Export Case.

      The Export Case button

      The Browser will open a file save dialog box.

  3. Select Save File.

  4. Click Ok.